View Full Version : Is there a limit on how many images you can view on FamilySearch?

22-03-12, 14:32
I always find that after I've viewed a few Norfolk PR / BT / AT images, I start getting error messages saying "Please try again later" with a code number below. Is it cutting me off because I've reached a limit of number of images viewed, or is it just that there are a lot of problems with those images? It always happens when I still have loads more stuff to look up!

22-03-12, 17:02
I didn't know you could view the images - just thought it was the transcription.

I have a wedding in 1825 in Cheadle, and wonder if I can see it - can I view the image and if so how?


22-03-12, 17:13
The Cheshire PR images aren't available on FamilySearch any more; now they are on findmypast.

If you want to know which FamilySearch databases have images, then on their front page, click on All Record Collections or on the country or continent that you want, and then it is the ones that have a picture of a camera next to them. But most of the time, at least as far as the UK databases go, there is no link between an indexed record and the image - you usually have to browse through images to get to the one you want.

If you go onto findmypast and search for the Cheadle marriage in their "Parish Marriages", hopefully there will be a VIEW button next to it, in the "Image" column.

22-03-12, 17:47
Are you signed in when this happens, Kite?

22-03-12, 18:41
I wasn't, but then I tried it when I was signed in and still got the same error message, but when I tried later I could view the images again. For a while.

22-03-12, 19:26
Does anything in here ring a bell?

22-03-12, 21:59
No, it's not that, Janet, because I was already browsing through images and it would suddenly stop showing them when I'd already viewed some. But thanks for the suggestion.

22-03-12, 22:50
Thank you so much - will have a look on fmp.

23-03-12, 00:21
Kate I spent days going through the cornwall parish register images and didn't have a problem except that they were slow to load. I ended up having 3 tabs open and would have them all open on the one register at different pages and it still didn't stop me looking. I don't think there is a limit and I wasn't logged in.

23-03-12, 07:08
Thanks, Kit. Maybe there is just a problem with the Norfolk ones then.

28-03-12, 13:27
I'm having the same thing happen again, on a different database, and I've managed to find a thread about it on FamilySearch's own forum:


So at least I know I'm not the only person it's happening to, although there is no solution given on that thread.